
Photographs & Linux
Overview / Intro

● First-order management of photos
– Many Images – cull / sort with gThumb

● Edit photos – The GIMP
● Album Creation – jAlbum
● Upload – Filezilla
● Presentation:

– Posted: NoVaLUG Presentations
– Composed with open source software
– Hardware: Appendix 8 Roger Broseus

NoVaLUG / Shropshire LUG, 2021.07.12
Slides: https://novalug.org/docs/gimp.odp (43 MB)

https://novalug.org/docs/gimp.odp

https://novalug.org/presentations.html
https://novalug.org/docs/gimp.odp
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The Power of The GIMP

St. Basil's Cathedral
Moscow

WireWire

Wire

Street
LightSt. Basils' Cathedral, Red Square, Moscow

Removed wires, street 
light

Improvee color balance

http://en.wikipedia.org/wiki/Saint_Basil's_Cathedral
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St. Basil's after Edits
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(Really) Fake News 1

N. Korea’s supreme leader, Kim Jong-un, was in the 
news for purging his uncle – erased from history.

Photo from the front page of the Wall Street Journal
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(Really) Fake News 2
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Another 
Miraculous 

Change . . . 

Lady in Museum 
Uglich, Russia

(before)

http://en.wikipedia.org/wiki/Uglich
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. . . (cont.)

Lady in 
Museum

(after)
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It’s Not Just About Editing (post processing)

Organize / Sort Images
● Managing large number of images
● Create a set (copy) of originals

– Recover from mistakes, e.g., accidental deletions
● Culling / Sorting
● Organize / create albums – jAlbum

– Appendix 1. – Description / Discount for NoVaLUG
● Alternatives

– gThumb – simple viewer
– DigiKam (KDE app) – it appears to have matured

● Filezilla for uploads to web site – Appendix 2.
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The GIMP

● GNU
● Image
● Manipulation
● Program
● Standard in many Linux distros
● Ports to Windows, MAC, and (reportedly) Android

● GIMP: $ 0
● Photoshop: $ 1k

– Subscription – $ 20+ / mo, plus for on-line storage
– Cloud dependent for some applications

http://tinyurl.com/q8duqev
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The GIMP

● Very powerful photo editor
● Pre-installed on many Linux distros

– Ubuntu/Debian, SUSE, Fedora, BSD systems, Windows, etc.; 
flatpak, .deb, RPM, even zipped for java-enabled systems

● Downloads – http://www.gimp.org/
● Active development

– Version 2.10.24 Released 2021-03-29
– Last presentation in  2013 based on Ver. 2.8

● Many alternate language versions

http://www.gimp.org/
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GIMP Documentation

● Extensive on-line help available
● User Manual / tutorial

– https://docs.gimp.org/2.10/en/
– Step-by-step procedures illustrated

● Tutorial
– https://www.gimp.org/tutorials/

● Grokking the GIMP (book)
– Google for free versions

● YouTube Videos – a plethora
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Bitmap vs. Vector Images

● GIMP: edit raster graphics file 
formats (bitmap images, 
e.g., .jpg, .gif) 

● Think pixels (digital “pointillism”)

● SVG – Scalable Vector Graphics

– XML-based vector image format
– 2-D graphics
– Support for interactivity and 

animation
– Edit with Inkscape – highly 

regarded drawing application
pixels.surat – zoom to illustrate

Vincent van Gogh, Self Portrait, 1887, pointillist.

https://en.wikipedia.org/wiki/Scalable_Vector_Graphics
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Customize GIMP
● GIMP can be highly customized

– Preferences
– Keyboard Shortcuts

● Chose System Theme – 

– Maximum contrast for presentation
● See Appendix 3 for more example Prefs
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 Tips: Keyboard Shortcuts

● Keyboard shortcuts – useful for
– commonly repeated actions
– Quick access to menu items
– Change with: Edit > Keyboard Shortcuts

● Appendix 4. Default Shotcuts
● Next slide – most used shortcuts
● Note: commonality across applications, e.g.

– ctrl-c: copy  ctrl-v: paste ctrl-x: cut & copy
– ctrl-shift-v: paste w/o formatting
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shortcut.favs
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Tips: File Types

● File formats .xcf files – GIMP's loss-less file format
– Intermediate  edits / layers / undo  are saved to .xcf
– No side-car files as opposed to other apps, e.g., Pshop

● “Lossy” formats –  .jpg, .gif
– Lossy image file compression
– Do not save and re save in lossy formats
– Lost: pixels (resolution), intermediate edits (no undo), layers (merged)
– .png – not lossy but no edit / undo data as compared with .xcf

● RAW – all of photo data retained – more color “depth”
● Edit w/ other apps, e.g., Darktable

– Darktable – links directly into GIMP
– RawTherapee (available as an appimage)

http://en.wikipedia.org/wiki/XCF_(file_format)
https://www.darktable.org/
http://rawtherapee.com/
http://rawtherapee.com/
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Tips (Cont.)

● Always use sRGB color profile for web (default)

● Setting sRGB color profile
– Image > Mode > Assign / Convert to Color Profile, 

or
– Select sRGB if GIMP prompts when image is 

opened
– See Appendix 5. for choosing colors, hex codes

● Color profiles with greater color depth are 
used for high quality printing, e.g., 16 rather 
than 8 bit
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Tips (cont.)

● Think ahead
● Optimize framing – avoid too tight

– Leaves room for cropping and other image edits
● Shoot at high resolution

– Preserves detail / facilitates “digital zooming”
● Make sure in-camera GPS is locked onto satellites

– To insure location of shot is correct
● Polarizing filter – circular for digital cameras

– The one filter to have
– Remove haze / glare / reflections
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Using Tools

● Open file: File > Open (ctrl-o)
● View grid: View > Show Grid
● Rotate

– Drag handles / fine tune with “Angle” / Click Rotate to 
commit) 

● Crop
– Icons may differ depending on theme, e.g., crop:
– Drag handles to adjust
– <enter> to commit

● Adjust color levels: Colors > Levels
● Save as .xcf file to retain changes
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Selection Tool – Options
● Rectangular

– Rounded corners
– Feather Edges

● Elliptical
– Hold SHIFT to get circle
– Feather edges

● “Free” Select / “Lasso”
● Selection can be drawn free-hand

– Sucesive shift-clicks for polygon
– Feather edges

● Concatenate Shift & select

● Crop – trim off edges
● Hint – when shooting, frame w/ extra 

space to allow for adjustments later
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Selections
Creating / Co-joining / Excluding

● Demo with colored layers
– Top layer: black (w/ white dot for positioning)

– Bottom layer: white
● Create a selection, e.g., w/ rectangle select 
● Add to it with Shift-drag for a chosen tool

– Can be different
● Omit an area from a selection with ctrl key

– ctrl-drag a selection tool
● Fill selected area with foreground color, black

– ctrl-, (ctrl-comma)
– ctrl-z to reverse change

select joint
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Color Selectors
● Color Selection Dialog – change foreground and 

background colors
– Swap color combo w/ small, overlapping boxes 

● Color Picker – select (change) foreground color
– Radius option determines how many pixels are selected 

– Monochrome selection: use very small radius
● Fuzzy select tool – select one region by color
● Select by Color – select all regions of a color

– Threshold option changes “purity” / 
monochromacity of color used for fuzzy 
and select by color

– Practical example: vary amount of non-
uniform sky captured. Demo: later.
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Move / Arrange / Alter Shape / Measure

● Move
● Rotate
● Resize
● Perspective alteration
● Flip

– Horizontal – click
– Vertical ctrl-click

● Measure
– Read angle at bottom of window

Many tools accessed 
with short-cut Keys

Default short-cuts: 
Appendix 4.
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Next - Examples - Basics

● Screen Capture
● Cropping, rotating / selections
● Color level adjustment
● Highlight an area

– Line drawing
– Create vignette

● MORE!
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Screen 
Shots

screen.shot / FF
https://is.gd/xfkWOU
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Screen Capture / Crop
● Bring object to shoot into view (browser)
● Switch focus to GIMP
● File > Create > Screen Shot

– Note – scan option is under File menu
– > Select a region to grab
– > Delay 5 sec
– > Click Snap

● Crop image
● Use handles to change

– Size
– Aspect

● Finish
– File > Save-as to keep as xcf
– File Export

Dilbert screen shot
https://is.gd/xfkWOU
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Straighten / Rotate / Crop / Color Levels / Drawing

Abu Simbel
(aerial view

abu.simbel.jpg

UNESCO site –
temples saved from 
submersion after 
formation of Lake 
Nasser by building of 
the Aswan High Dam.

Temples were 
massive structures 
which were cut-up, 
from solid rock, 
moved to higher 
elevation, and pieced 
back together.

http://en.wikipedia.org/wiki/Abu_Simbel_temples
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Straighten (Rotate)

● Safety: Duplicate layer, blank it
– Work on copy

● Use rotate tool – Click to activate
– Cursor changes to rotate tool

● Click-drag near image corner
– Image rotates
– See semi-transparent preview

● Change angle with drop-down / up arrow
● Click Rotate to complete

– Note empty pixels around edges - no data 
there

● Crop
● Use corner and edge handles to adjust size
● ENTER to complete crop

Problem: hard to align with 
rotate alone

Grid Lines can help

More precise: use Measure tool

Reverse changes with Undo – 
Shortcut ctrl-z

abu.simbel.jpg
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Align –
Measure Tool

● Click on Measure tool 
● Right-click-hold-drag along horizon
● See inclination at bottom – 4.2°

● Activate Rotate Tool
● Left-click on image
● Adjust Angle to - 4.2°   (minus 4.2°)

● TAB to see effect
● Click Rotate to accept

● CROP to area of interest
– Removes airplane engine, etc.
– ENTER to commit

abu.simbel.cropped.xcf
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Drawing Lines

● Activate Pencil tool
– Opacity: 100 (not semi-transparent)
– Hardness: 100  solid (not feathered)
– Size: adjust with up / down arrows to 3px
– Color: Black

● Irregular line: left-click-drag cursor  – release
● Straight Line

– Move cursor to Start Position, cursor and left-click
● A dot appears

– Position cursor at end point
– ctrl-shift to align in 15° increments
– Left-click to close line

● End-point can be beginning of new line segment

abu.simbel.cropped.xcf
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Exposure / Color Adjustments

● Very useful tool – Colors > Levels  (my custom shortcut: ctrl-L)

● Adjust overall “lightness” / “darkness”
● Compensate for some exposure problems
● Improve color balance
● Save / Use presets to apply levels to multiple 

images
● Example – histogram for Abu Simbel image
● Not in-camera histogram – image histogram 

rendered by GIMP
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Histograms: 
Loaded

With Info
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Understanding Histograms

● Horizontal axis:
– Represents the 

tone of a color
– Far right: pure 

white
– Far left: pure black

● Vertical axis:
– Number of pixels 

for a given tone

Histogram
(Abu Simbel Image)

IDEAL: Data all 
in center, tailing 
off left & right

Histogram views are built-in 
to modern digital cameras.

Improve images in post 
processing using Levels to 
“manipulate” histogram.”
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Levels
Color Balance

● Menu
– Color > Levels

● My Shortcut for a frequently used tool
– ctrl-l (ctrl - el)

● Drag arrows to adjust tones:
● This example:

– Dark tones: 50
– Mid tones: 1.10
– Light leave at 255

● Note options to toggle Preview, reset, 
cancel

● Click OK to commit
● More about histograms Appendix 6

abu.simble.levels.demo.xcf



  35

Compare Sky Histograms
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Example – Astro Photography

Wanted:

  Got:
                        (White specs are stars)
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Before & After Level Adjustment

milky.way.level.adjust.xcf
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Limitations of Level Adjustments
● Won't compensate for:

– Excessive under exposure
– Over exposure (“blown-out” areas of images)

● Common issue in landscape photography
● HINTS: 

– Avoid harsh shadows, extremes of light intensity
– Shoot w/o direct sunlight – mornings /  evenings

● Modern digital cameras – HDR
– Extend latitude with High Dynamic Range – In Camera!

● Post processing of images
– Photo stacking multiple exposure shots, but not easily in The GIMP
– Start post processing with RAW images, switch to GIMP
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Clone Tool

cows.costa.rica.xcf

● Backup original – dup 
layer, blank it – focus visible 
layer (blue highlight)

● Levels (ctrl-l)
● Pick white and black points

– Small picker size

– Adjust mid-tones to ~ -1.55
● Correct slight blue cast

● Value drop-down

● Adjust Output Level to ~248

● Continue: remove wires and pole
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Clone Tool
● Adjust view: Zoom-in shift +
● Activate clone tool           (icon is like an old rubber stamp)

● Adjust properties
– Brush hardness: 2
– feathers edges
– Brush size – slider:  ~32 (or use custom +/- wheel)

● Select area to clone: ctrl-click just below wire
● Left-click to drop cloned area
● Position cursor further along wire, left-click

cows.costa.rica.xcf
(cont.)
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Clone Tool – Remove Pole (cont.)

● Enlarge selection area to ~50  (shift-ctrl +/- wheel)

● Left-click near top of pole
– Don’t catch pole in edge of selection area

● Center cursor directly to side of clone area, centered on 
pole

● Left-click
● Move cursor to bottom / center of pole
● left-click
● pole disappears
● Note also randomness of leaves / soft brush fills-in the 

pole area
● Illustrate with layers on / off cows.costa.rica.xcf

(cont.)
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Script-Fu
Sky Replacement
● Script-FU > Darla > Blue Sky 

Gradient
● OK, nice blue sky, BUT

– Whiter areas now blue, e.g., spot 
on cow’s hide, car, etc.

● Backing up:

– Undo: ctrl-z, or, delete top layer
● Select sky: lasso tool, feather ~10

– Include sky showing thru trees; close selection: click 2x
● Repeat script

– Merge layers; Crop; Save-as  /  Export-as
● Obtain / Install  info – Darla’s script: Appendix 7 cows.costa.rica.xcf

(cont.)
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Putting It
All  Together

● Creating selections
● Modify selections

– Tools
– Tool options

● Work with Layers
● Create a vignette

– (from screen shot of a

virtual NoVaLUG meeting)
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Selection / Modifying

Open image to be edited (a screen 
shot)

Improving the "look" - transplant some 
hair

- Free / lasso
- Tool Option > Feather edges (25)

- Select some beard w/ lasso
- ctrl-c copies selection
- ctrl-v pastes

Notice: a new layer appears
- right-click on layer > To New Layer
- Activate Flip tool - click it
  ctrl-click inverts selection
- Activate move tool - click it
- drag selection to reposition
- Duplicate layer

- Move to position the new layer
- Flip the layer horizontally
- Adjust position, size

Move tool 
Scale tool
Rotate tool
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Consolidate the Image

● Select the Layers Tab
● Highlight the layer to merge down
● Right-click-hold on the layer

– Action list appears
● Mouse down to Merge Down
● Release to activate Merge
● Other actions available, e.g.,

– New Layer from visible
– Layer Visibility toggle w/ eye 

icon
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Summary
Flip / Move tools

● Paste selection to new image
● Other tools can be applied to active selections
● Make a mirror image of selection

– Duplicate selection: Edit > Paste (ctrl-v)

– Flip selection (flip tool)

– Position (move tool)

● Can also Resize (scale tool)
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Creating A Vignette
● Ellipse Tool

– Tool options > Feather > 100
● Create elliptical selection
● Invert selection

– Select > Invert
– Notice dancing ants

● Color Tool: select black
● Fill w/ foreground color

– Edit > Fill w/ FG color  (or ctrl-,)
– Unselect: ctrl-shift-a

● Finish: crop, save, print, frame
slelections.vignette.xcf



  48

More About Layers

● Layers enable many tricks
– e.g., re-use of image

● Previously added layers retained in .xcf files
● Create different versions of image

– Selectively hide / reveal layers
– Save each as, e.g., .jpg files for later use

● Illustration – map labeling to illustrate trip 
progression
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Reuse 
“Master” 
Image

map.layers.xcf
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Red Eye Removal

● Zoom-in (shift-+) to area of interest
● Select pupil w/ Ellipse tool (no feather)
● Filter > Enhance Red Eye Removal

– Adjust Threshold
– Click OK to commit (accept defaults)
– Unselect: ctrl-shift-a

● Enhancement – Add sparkle, like left eye

red.eyed.cat.xcf
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Enhancement (cont.)
● Zoom-in / sliders – center eyes in view
● Select highlight from left eye

– Ellipse tool, feather 5 (no sharp edges)

● Copy / Paste selection: ctrl-c, ctrl-v
● Layers: notice floating selection
● Position over right eye: move tool
● Merge down: ctrl-m
● Zoom to original size: ctrl-0 (ctrl-zero)
● Done: Save

red.eyed.cat.xcf
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Free Select / “Lasso” Tool

● Free select tool
– “lasso tool”
– polygonal segments or irregular shapes

● Select modes
– Freehand
– Polygonal segments
– Point-to-point

● Complete selection by “closing” selection
– Or, do final click on first selection handle
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Demo – Free select (and copy)

● Freehand: just drag cursor around area to 
select

● Polygonal: do a series of shift-clicks
● Irregular: do a series of clicks

– Allows finer control of selection area
● Edit > copy or ctrl-c to copy selection while it's 

active

select.lasso.xcf
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Perspective – 
Before Changes

Improved 
Perspective
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Perspective Tool
● Useful to correct distorted perspective, especially in images with 

obvious right-angles
● Helpers

– Expand window (grab a corner and drag)
– Grid lines: View > Show Grid    (my custom: ctrl-g)

● Adjust perspective: drag corner handles
– Perspective parameter box appears

● Commit: click on Transform button
● Some of image is lost – null / checkerboard areas

– Hint: loosely framed image when shooting to allow room for adjustments
– Crop to finish
– Adjust Levels to “brighten”  0  /  1.15  /  225
– File > save-as (xcf to retain edits)    or File > export as other format.

perspective.art.xcf
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Geometric Shapes
GIMP is not a “drawing” program

● GIMP: raster graphics vs. vector graphics (Inkscape)
– Ref: vector vs. raster graphics editors

● Construct geometric figures using built-in tools
● Example: area of interest – Abu Simbel
● Activate Ellipse tool

– Drag cursor, encircle area of interest, change shape
– Shift-drag to create circle

● Make it red – Color selector, chose red
● Edit > Stroke selection 

– Line width: 4
– Click Stroke to commit

● Oops: too thin – ctrl-z 
– Edit > Stroke selection > Line width 6 > Stroke
– ctrl-shift-a to deselect; save for posterity

● Option: Enlarge area of interest: Zoom-in (Shift +); avoid pixelation; crop to 
area of interest; save-as or export-as.

abu.simbel.cropped.xcf

http://tinyurl.com/laohykn


  57

● Create a Green Square
– New image
– ctrl-n
– Ok

● Rectangle select, option Expand from Center
● Color: green – by name in HTML box; Enter; OK
● Edit > Stroke Selection > Line width: 5; Okay
● Unselect:  ctrl-shift-a

● Use on another image: ctrl-a; change focus to other image; crtl-v

● Ovals: Stroke Ellipse selection
● Concentric circles – brute force: do concentric circle selections and fill thin 

gap with a color
● Imaginative use of selectors to make interesting shapes
● Graphic pens work well with GIMP

Other Shapes

Green 
Square
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Shape Creation with Selectors
6-Point Star / Highlighted Text

Create star in steps using rectangular selector 
and Edit > Stroke – steps illustrated with layers

● Trim insides
● Text-tool to create WOW (black) in new layer
● Select-by-color      black text
● Change color to red
● Stroke selection – Edit > Stroke

– Line width: 1 > Stroke
● Finish: ctrl-shift-a; save (preserves .xcf); export as; ctrl-q (quit)

wow.xcf
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Five Point Star

● Created with a combination of lines 
radiating from a point at 
successively increasing 36° angles

● Draw point-to-point lines from vertices 
delineated by intersection of lines with circles

● Will briefly illustrate but details are left as an 
exercise for the “student”

start.five.point.xcf
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Water Mark
● Create new layer 
● Text Tool

– Click image where text is desired
– Blank image layer 

● Choose font attributes
– Size: ~ 70 Color: Blue
– Click font attributes

● Bold, Italic, Underline
– Tab to enter text box

watermark.xcf
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Water Mark (cont.)
● Adjust text box position – drag 

corners and edges
● Adjust Opacity: ~ 60
● Change angle – Rotate Tool

– shift-drag rotates in 15° increments
● Position with Move Tool
● Save-as; export-as; ctrl-q 
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Color to Black & White

● B&W sometimes better than in color
● Compensate for severely distorted color 

balance
● Fix by changing to B&W
● Example: old photo color distorted due to age
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Example – Before and After

Convert with

  Image > Mode > Grayscale

Adjust color Levels

Fuzziness: camera limitations
cousins.original.jpg
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The End - Acknowledgments
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Appendix 1. jAlbum
Create / Organize Albums

● Powerful, feature laden
● Final organize re-arrange photos
● Annotate with comments visible to viewer on web
● Numerous skins
● Favorite skin: Tiger, ZigZag, Atom (simple, quick)
● Responsive design – view on tablets, smart phones
● Geo-location: location of photo on Google Maps
● Handles videos
● Some editing capbilities built-in

http://jalbum.net/en/skins
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App. 1. jAlbum (Cont.)

● Active user forums w/ answers
● Server side software not required
● One month free trial 2 GB on-line storage at 

jAlbum.net
● Free to use / license to get rid of ads (see FAQ)

– jalbum.net
● Fast / smart upload tool

– Doesn’t re-load existing images

http://tinyurl.com/k87kpzu
http://jalbum.net/en
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● 40% discount code

– novalug21
– Valid until 2021.08.10
– A “rare” discount, courtesy of David Elkholm, 

jAlbum developer

App. 1. jAlbum (Cont.)
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App. 1. jAlbum (Cont.)

● Use jAlbum for album creation and cull / sort / order in jAlbum.
● Can jump directly to GIMP when set as external editor
● Images commonly download from camera arranged by date, 

usually OK. One can also move images into folders with 
appropriate names using tools for viewing folders – such as 
Konqueror or Nemo. Then jump to jAlbum.

● Jalbum has options to tag photos, including a “star” rating, 
helpful when culling.

● What method is choosen for various tasks, don’t jump around – 
interface confusion ensues

● Be sure to make a backup copy of originals as a first step.
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Appendix 2.
Album Uploads – Filezilla

● Fast – multiple upload “threads”
● Nice GUI
● Site manager – set i.p., etc., forget
● Secure connections – 

– SFTP
– Public / private key

● Selectively upload only new files
● If uploading jAlbum – all files in

– /MyAlbums/<album name>/album
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Appendix 3
Example Preferences

● Toolbox
– Tools to display
– Arrange tools

● Default new image
– Size, Resolution
– Color space profile
– My preferred fill: transparent

● Policy, File open
– Default for web work
–

– Convert to sRGB
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App. 3 – Prefs 
(cont.)

● Maximize 
contrast:
– In addition to 

setting the 
Interface 
Theme to 
“System”

– Also adjust 
Icon Theme
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Example Preferences (cont.)

(Beyond the scope
of this presentation!)



  73

 Appendix 4. Shortcuts (default)
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Appendix 5. Color Chart Refs
● Color charts / color hex codes
● Html color chart 

– Chart
– Color picker
– Color code theory
– Examples – next slide

● Color Picker
● Color wheel

– Hex codes for color
– Several color tools

https://html-color-codes.info/
https://www.colorschemer.com/color-picker/


  75Source: https://html-color-codes.info/

App. 5 (cont.)
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App. 6  Understanding Histograms
● Camera Histograms reveal underlying data about exposure 

of a photograph. Understanding of them can extrapolated to 
editing (Color > Levels)

● Over exposure: histogram touches the right edge of the 
graph for some areas of image.

● Under exposure: histogram touches the left edge of the 
graph for some areas of image.

● Photos are composed of pixels. The camera picks up the 
tone of each of those pixels, regardless of color. Tone / 
luminosity – bright? Dark?

● In a camera, software changes pixels to white, black or 
different shades of gray, depending on the brightness or 
darkness of a tone. Normally up to 256 light values – levels – 
are used to generate the histogram.
– Lastly, the camera's software algorithm counts the number of 

pixels of each tonality and builds a bar chart – the histogram.
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App. 6  Understanding Histograms (cont.)

● A camera’s histogram shows all the light values it has capture. It shows 
the tones that fit within the dynamic range of the camera are distributed.

● Between the tone located at the left and right ends of a histogram there 
are a certain number of stops, which correspond to the dynamic range 
of a camera.

● The aim is to avoid blown out highlights and clipped shadows. Likewise, 
a GIMP histogram reveals the areas that are over exposed and under 
exposed.

● Adjusting Color Levels in GIMP can bring out data in underexposed 
areas. Parts of an image that are “blown out” are lost.

● A GOOD histogram shows peaks towards the center of the graph from 
left to right. The majority of the pixels in the image are mid-tones; fewer 
pixels makeup the shadows and highlights. It's a great histogram.

● Ref: photopills.com – Milkway Guide

https://www.photopills.com/
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App. 7. Darla’s Sky Replacement Scripts

● Instructions / obtain Darla’s sky scripts
– Blue Sky Gradient
– Blue Sky Clouds

● Installation, clouds script
● Downloaded script from github

● Copied text of scrip, while displayed in browser
● Saved as sky.clouds.scm to /home/roger/.cconfig/GIMP/2.10/scripts/

● More tips on installing GIMP plugins
– plugins on-line-tech

https://farcrydesign.com/GIMP/BlueSkyGradient.html
https://farcrydesign.com/GIMP/BlueSkyClouds.html
https://github.com/pixlsus/registry.gimp.org_static/blob/master/registry.gimp.org/files/Darla-BlueSkyClouds.scm#L1
https://www.online-tech-tips.com/computer-tips/installing-gimp-plugins-a-how-to-guideh-tips
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App. 8  PC Used for this Project

Building the PC

https://bronord.com/pics/pc.build/index.html
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Appendix 9.
My Equipment

● Olympus micro four-thirds
– Light weight
– Compact
– Shirt pocket size (almost)
– Highly recommended for 

travel photograhy
● Tripod; Monopod; Filters: 

star; circular polarized; 
spare batteries, charger
(Appendix continued – next slides)
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App. 9 
(cont.)

OM-D E-M10 
Mark III, 16 Mega 
Pixel

Newer, Mark IV: 
20 Mega Pixel
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App. 9 
(cont.)

Lenses: Multiply focal 
length 2x to get 
approximate 35mm 
camera equivalents. The 
pancake lens (zoom) 
focal length is 14 – 
42mm, ~equivalent to 28 
– 50mm focal length for 
a 35mm camera.

The 40 – 150 zoom lens 
is ~equivalent to 80 – 
300mm.

These are lower priced 
lenses. “Prime” lenses 
are higher quality.
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